Home | News | Download | Packages | Forum | Wiki | Github

Kernel panic on 4.15


#1

Hi, i am getting kernel panic every time i shutdown my machine, the kernel panic happens after the process killed, so i was unable to get the logs, but i killed my X process and then the panic happened, i was able to get the logs, here is ->

    2018-04-07T22:18:39.18134 kern.err: [33327.293313] list_add corruption. prev->next should be next (0000000046b94e46), but was 000000004341dd80. (prev=000000003e03fecf).
2018-04-07T22:18:39.18139 kern.warn: [33327.293385] ------------[ cut here ]------------
2018-04-07T22:18:39.18141 kern.crit: [33327.293386] kernel BUG at lib/list_debug.c:28!
2018-04-07T22:18:39.18142 kern.warn: [33327.293441] invalid opcode: 0000 [#1] PREEMPT SMP PTI
2018-04-07T22:18:39.18143 kern.warn: [33327.293495] Modules linked in: xt_recent ip6t_REJECT nf_reject_ipv6 nf_log_ipv6 xt_hl ip6t_rt nf_conntrack_ipv6 nf_defrag_ipv6 ipt_REJECT nf_reject_ipv4 nf_log_ipv4 nf_log_common xt_LOG xt_limit xt_tcpudp xt_addrtype nf_conntrack_ipv4 nf_defrag_ipv4 xt_conntrack ip6table_filter ip6_tables nf_conntrack_netbios_ns nf_conntrack_broadcast nf_nat_ftp nf_nat nf_conntrack_ftp nf_conntrack libcrc32c crc32c_generic iptable_filter ip_tables x_tables nls_iso8859_1 nls_cp437 vfat fat snd_hda_codec_via snd_hda_codec_generic snd_hda_codec_hdmi r8169 snd_hda_intel snd_hda_codec joydev coretemp input_leds intel_rapl iTCO_wdt snd_hda_core x86_pkg_temp_thermal intel_powerclamp shpchp iTCO_vendor_support lpc_ich snd_hwdep snd_pcm intel_cstate intel_rapl_perf i2c_i801 thermal evdev pcspkr mac_hid fan eeepc_wmi asus_wmi
2018-04-07T22:18:39.18146 kern.warn: [33327.293982]  sparse_keymap wmi_bmof snd_seq snd_seq_device snd_timer snd soundcore vhost_vsock vmw_vsock_virtio_transport_common vsock vhost_net vhost tap uhid hci_vhci bluetooth ecdh_generic rfkill vfio_iommu_type1 vfio uinput userio ppp_generic slhc tun loop btrfs xor zstd_compress raid6_pq zstd_decompress xxhash cuse fuse ext4 crc16 mbcache jbd2 algif_skcipher af_alg dm_crypt hid_generic usbkbd usbmouse usbhid hid sd_mod ata_generic pata_acpi nouveau mxm_wmi hwmon i2c_algo_bit crct10dif_pclmul crc32_pclmul crc32c_intel ghash_clmulni_intel pcbc drm_kms_helper syscopyarea sysfillrect sysimgblt fb_sys_fops ata_piix ttm aesni_intel ehci_pci aes_x86_64 libata ehci_hcd crypto_simd glue_helper drm cryptd usbcore scsi_mod agpgart wmi video button dm_mirror dm_region_hash dm_log dm_mod
2018-04-07T22:18:39.18148 kern.warn: [33327.294954] CPU: 6 PID: 329 Comm: kworker/6:1 Not tainted 4.15.15_1 #1
2018-04-07T22:18:39.18149 kern.warn: [33327.295177] Hardware name: System manufacturer System Product Name/P8H61-M LX3 R2.0, BIOS 1107 02/25/2014
2018-04-07T22:18:39.18150 kern.warn: [33327.295416] RIP: 0010:__list_add_valid+0x4a/0x70
2018-04-07T22:18:39.18151 kern.warn: [33327.295647] RSP: 0018:ffffb9ab811b3d98 EFLAGS: 00010082
2018-04-07T22:18:39.18152 kern.warn: [33327.295891] RAX: 0000000000000075 RBX: ffff93c51fda4f00 RCX: 0000000000000000
2018-04-07T22:18:39.18153 kern.warn: [33327.296132] RDX: 0000000000000000 RSI: ffff93c51fd964f8 RDI: ffff93c51fd964f8
2018-04-07T22:18:39.18154 kern.warn: [33327.296377] RBP: ffff93c51fda0ec0 R08: 0000000000000000 R09: 0000000000000419
2018-04-07T22:18:39.18154 kern.warn: [33327.296629] R10: 0000000000000000 R11: ffffffff9d3be040 R12: ffff93c51fd9f288
2018-04-07T22:18:39.18155 kern.warn: [33327.296885] R13: ffff93c51fda0ee0 R14: ffff93c50f968e18 R15: ffff93c51fd9f290
2018-04-07T22:18:39.18156 kern.warn: [33327.297143] FS:  0000000000000000(0000) GS:ffff93c51fd80000(0000) knlGS:0000000000000000
2018-04-07T22:18:39.18157 kern.warn: [33327.297405] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
2018-04-07T22:18:39.18158 kern.warn: [33327.297671] CR2: 00000000000000b0 CR3: 00000001a600a004 CR4: 00000000001606e0
2018-04-07T22:18:39.18159 kern.warn: [33327.297945] Call Trace:
2018-04-07T22:18:39.18159 kern.warn: [33327.298223]  insert_work+0x47/0xb0
2018-04-07T22:18:39.18160 kern.warn: [33327.298499]  __queue_work+0x10f/0x440
2018-04-07T22:18:39.18161 kern.warn: [33327.298773]  queue_work_on+0x33/0x40
2018-04-07T22:18:39.18162 kern.warn: [33327.299062]  put_task_stack+0x75/0xe0
2018-04-07T22:18:39.18162 kern.warn: [33327.299329]  finish_task_switch+0x1d5/0x230
2018-04-07T22:18:39.18163 kern.warn: [33327.299613]  __schedule+0x32a/0x7c0
2018-04-07T22:18:39.18165 kern.warn: [33327.299896]  ? free_work+0x21/0x30
2018-04-07T22:18:39.18165 kern.warn: [33327.300183]  schedule+0x2f/0x90
2018-04-07T22:18:39.18166 kern.warn: [33327.300474]  worker_thread+0xad/0x380
2018-04-07T22:18:39.18167 kern.warn: [33327.300762]  ? process_one_work+0x3e0/0x3e0
2018-04-07T22:18:39.18168 kern.warn: [33327.301054]  kthread+0x113/0x130
2018-04-07T22:18:39.18169 kern.warn: [33327.301353]  ? kthread_create_on_node+0x70/0x70
2018-04-07T22:18:39.18169 kern.warn: [33327.301645]  ? SyS_exit_group+0x10/0x10
2018-04-07T22:18:39.18171 kern.warn: [33327.301945]  ret_from_fork+0x35/0x40
2018-04-07T22:18:39.18172 kern.warn: [33327.302247] Code: 01 00 00 00 c3 48 89 d1 48 c7 c7 50 11 d8 9d 48 89 c2 e8 34 a0 d8 ff 0f 0b 48 89 c1 4c 89 c6 48 c7 c7 a0 11 d8 9d e8 20 a0 d8 ff <0f> 0b 48 89 f2 4c 89 c1 48 89 fe 48 c7 c7 f0 11 d8 9d e8 09 a0 
2018-04-07T22:18:39.18174 kern.alert: [33327.302903] RIP: __list_add_valid+0x4a/0x70 RSP: ffffb9ab811b3d98
2018-04-07T22:18:39.18176 kern.warn: [33327.303214] ---[ end trace 06f2acc6e4c03dab ]---
2018-04-07T22:18:39.18177 kern.info: [33327.303537] note: kworker/6:1[329] exited with preempt_count 2

#2

Not very surprising. Try another kernel release.


#3

have been getting the same here with 4.15, and with 4.16 too.
4.14 works fine…
something changed in the compilation process/flags?
might add that 4.15 of another distro on this machine works fine…


#4

for me 4.16 works well, and 4.9 is very stable too.
I tried 4.15 on another distro (Arch) and I got the same kernel panic at shutdown! :grimacing:


#5

I updated to 4.16 like cr6 said, and its working pretty well ( nothing happen yet ), every release of 4.15 give that kernel panic, on 4.14 works fine too.

I have void on another computer with 4.15, and works with no errors.

Edit: I am running i3wm directly with startx, thats log above i get when i killed my X proccess.


#6

So… unfortunately i got kernel panic on 4.16 too :confused:.

Same thing, shutdown -> Kernel Panic with the same log above


#7

so maybe, let’s compare hardwares… mine is:
Intel® Core™ i7 CPU Q 720
with this microcode inserted:

 sudo dmesg | grep micro
[    0.000000] microcode: microcode updated early to revision 0x7, date = 2013-08-20
[    1.601944] microcode: sig=0x106e5, pf=0x10, revision=0x7
[    1.602631] microcode: Microcode Update Driver: v2.2.

#8

@ncmprhnsbl ah yes! you rightly remind us of that.

@Nokogiri please ensure that you have installed the latest microcode update for your CPU.


#9

In wich package i can find the microcode?


#10

@Nokogiri
Please reference: [solved] Intel-ucode


#11

I will try, thx


#12

:grinning: i was actually thinking the opposite: that the microcode might be the problem and removed it to see what would happen, but this made no difference.
now i’m wondering, since nokogiri is getting kernel panic when killng X, that maybe it’s related to the video driver…
mine is:

 lspci | grep VGA
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Madison [Mobility Radeon HD 5730 / 6570M]

using the radeon kernel module…


#13

I updated my microcode, i will check if is REALLY the X proccess,

my video driver:

01:00.0 VGA compatible controller: NVIDIA Corporation GM206 [GeForce GTX 960] (rev a1)

using Nouveau


#14

Really happens when i kill my window manager (i3), exactly on that line on
/etc/runit/3
msg "Sending TERM signal to processes..." pkill --inverse -s0,1 -TERM sleep 1

I think the way is dive into that

ncmprhnsbl & cr6, could you try find what is making the panic on your machines ? what part of the stage 3 is doing that or what process.


#15

@Nokogiri 4.15 is no longer installed on my pc, I removed it a long time ago! :sweat_smile:


#16

killing X didn’t cause kernel panic here
in my case, i just did: #sv stop lxdm


#17

And if you use 4.16.2 instead, does it solve your issue?


#18

no, for me, 4.16 and 4.15 both kernel panic on shutdown, which is:
sudo /sbin/shutdown -h now in my openbox menu…
afaict it happens after all services have been stopped…


#19

4.16.2 doesn’t help either. i use the same command to shutdown my system, i will try another distro with kernel >=4.15 to check.