Home | News | Download | Packages | Forum | Wiki | Github

Just wanted to let you know... Plasma is close, it is here


#1

Well, from time to time I like to see what new packages are added to the repos, and when I looked at the feed in the main page I could not believe my eyes. Plasma was finally accepted! The build for plasma-desktop fails in travis, which is not a great indicator, but if it was accepted it may be that it was shown to build correctly!

I believe now some testing will be required to make sure it works as expected, so I would like to ask everyone who likes (or would like to get a feel of) Plasma to try it out and find issues with it! Also, there are A LOT of packages missing that are usually used in-with Plasma (themes, extensions, etc), but now it will be up to us, the community to add them! :smiley:

P.S: it just so happened that I reinstalled my Antergos (Arch) installation with Plasma this last weekend since my situation with GNOME had gotten worse as time progressed, and I started wondering when would I finally be able to try Plasma in Void. What good timing!


#2

I’ve just tried Plasma and it works flawlessly!
Although it appears to need ‘qt5-tools’ to start else it just displays a message saying 'Could not start d-bus. Can you call qdbus?'
It’s awesome to finally have Plasma on Void.


(David Lebel) #3

I noted that its still 5.8.x… Any plan to push 5.10?

EDIT: I understand that 5.8 is an LTS release, that might be the reason why.


(Frankie Wilde) #4

Hmm I have tried that too but ended up with a black screen. Otherwise I can run krunner and any other application but I have no panel and have to disable compositing to see any background. I guess plasmashell is crashing on me… Would you mind posting your set up like video card used and what other desktop environment are you running ?

Thanks.


#5

If you can log in to plasma but get a black screen you might be missing the ‘plasma-desktop’ package.
I got plasma running in QEMU/KVM and on an AMD R9 280.


(Frankie Wilde) #6

I have it installed. It seems rather something related to compositing and the shell itself crashing before showing the desktop but I can’t find any log output to see exactly what happens.


#7

To see the log of Plasma, use another desktop environment and in a terminal run ‘startkde --replace’ when it crashes you should be able to see what caused it.


(Frankie Wilde) #8

Thanks, as expected decorator fails this way.

https://pastebin.com/bVdu4xUM


#9

I think you just need to install ‘xset xsetroot xprop’, if that dosen’t work try installing the whole xorg meta-package.


(Frankie Wilde) #10

Tried both suggestions, no change, but that reminds me that in the past I tried compiling Plasma from scratch and might have some leftovers in system files like the kf5 library which I am pretty sure I didn’t remove after the attempt. I will try a fresh install in docker or virtualbox to eliminate those factors.


(Frankie Wilde) #11

Report from a virtualbox session. I managed to reproduce the bug and it’s the same message output from “startkde --replace” as on my physical installation:

KActivities: FATAL ERROR: Failed to contact the activity manager daemon - remaining

It actually booted fine the firs time. After a restart of the VM I got the same effect as on my physical machine - black screen, cursor, krunner working.

P.S. The culprit of this seems to be:

QSqlDatabase: QSQLITE driver not loaded
QSqlDatabase: available drivers: QSQLITE3

There is a mismatch between the driver attempted to be loaded and the driver available. This is sovled by installing qt-plugin-sqlite-4.8.7_23


#12

On my system ‘kactivities5’ pulled in ‘qt5-plugin-sqlite’ as dependency. So maybe something weird happend to the dependencies on your install.


(Frankie Wilde) #13

Yes, I have it too but I don’t think it’s specific to my install only since the same happened on a separate virtualbox installation. I believe it’s a bug but can not yet detect what triggers it.


(Frankie Wilde) #14

Culprit found as suggested by this post:
https://forum.kde.org/viewtopic.php?f=289&t=125143

Along with sgclark we managed to determine that this is caused by Plasma 4 packages getting mixed with Plasma 5 packages, resulting in magical spagetthi of broken dependencies…

It happens when you install konsole… It pulls kactivities4, kde-libs and kde-baseapps which completely messes up the dependencies.

In conclusion: don’t install konsole for now and it should work but the fact that kde4 and plasma dependencies can mix up in general gives it status unstable for the time being.

Where to track progress, basically apps are yet to be ported for Plasma 5: https://github.com/voidlinux/void-packages/issues/4963

Thanks for the hard work @dutsky


#15

The plasma meta-package should probably conflict with the kde4 packages to stop them mixing up.


(Frankie Wilde) #16

Another thing I have noticed is that I can not recursively remove those packages at the moment. As soon as I go with xbps-remove -R plasma-desktop it hangs indefinitely not giving any feedback at all. The same applies for kde5 meta package.


#17

I’ve noticed that happen when recursively removing packages with lots of dependencies like gnome.


#18

It turns out it will eventually finish if you just leave it running for ages, it uses 100% of a single core on my CPU so I guess it takes so long because it only uses one thread.


(Frankie Wilde) #19

After full xbps-remove -R kde5 and manually removing every single trace left of kde4 packages and xbps-install -S kde5 it’s all working now.


#20

Good to know it’s all working now :smiley: