Home | News | Download | Packages | Forum | Wiki | Github

INTEL and AMD Graphics


(Malte) #1

HI Guys,

I have this hardware:

00:02.0 VGA compatible controller: Intel Corporation HD Graphics 620 (rev 02)
01:00.0 Display controller: Advanced Micro Devices, Inc. [AMD/ATI] Topaz XT [Radeon R7 M260/M265 / M340/M360 / M440/M445] (rev 83)

It is a AMD Radeon R7 M440.
This packages I have installed:

linux-firmware-amd-20170622_1
xf86-video-amdgpu-1.4.0_1

Did I missing something? I want to play some steam games, but I have really bad graphics and fps.
Maybe somebody could help me.


#2

AMD Radeon R7 M440 is a GCN 1 card and by default will use the radeon driver not the amdgpu driver. You’ll probably need the xf86-video-ati driver as well.

Run xrandr --setprovideroffloadsink radeon Intel
This will force your radeon card to render when the DRI_PRIME=1 variable is set.

Run this to check whether that works:
DRI_PRIME=1 glxinfo | grep "OpenGL renderer"
It should output something like this.
OpenGL renderer string: Gallium 0.4 on AMD

So to play Steam games on your AMD card run steam as env DRI_PRIME=1 steam


(Malte) #3

I tried, but get an error:

# xrandr --setprovideroffloadsink radeon Intel
Could not find provider with name radeon

[root@lin .scripts]# xbps-query -Rs radeon
[-] radeontop-v1.0_1          View radeon GPU utilization
[*] xf86-video-amdgpu-1.4.0_1 Xorg AMD Radeon RXXX video driver (amdgpu kernel module)
[*] xf86-video-ati-7.10.0_1   Xorg ATI Radeon video driver

[root@lin .scripts]# DRI_PRIME=1 glxinfo | grep "OpenGL renderer"
OpenGL renderer string: AMD Radeon (TM) R7 M340 (AMD ICELAND / DRM 3.18.0 / 4.13.12_1, LLVM 4.0.1)
[root@lin .scripts]#

#4

It looks like xrandr --setprovideroffloadsink radeon Intel wasn’t needed as just using DRI_PRIME=1 has worked on it’s own, as DRI_PRIME=1 glxinfo | grep "OpenGL renderer" outputs the radeon card instead of the intel one.


(Malte) #5

Ok, thanks for your help


#6

If perf is still slow, you may need to install some 32-bit components of the graphics drivers. I can’t remember the package names, but possibly it was mesa-ati-dri-32bit for me.