Home | News | Download | Packages | Forum | Wiki | Github

How to replace NetworkManager with wicd?


(Борисав Живановић (Borisav Živanović)) #1

I am using VoidLinux with XFCE desktop and I’ve uninstalled NetworkManager and installed wicd and wicd-gtk but when I boot my computer and login a message pops up saying that “Could not connect to wicd dbus”. I have to manually run wicd daemon as root in order to get networking to work.


Wpa_supplicant and dhcpcd require restart after reboot
#2

Hi @borisavz

  • Make sure you have disabled dhcpcd / dhclient / wpa_supplicant services.
wicd-1.7.4_2: post-install message:
========================================================================
Please note that wicd does not require to have dhcpcd and/or
wpa_supplicant services running at boot. If you are using them at
boot, please disable them before using wicd. You can do that with:

	# rm -f /var/service/{dhcpcd,wpa_supplicant}

ATTENTION: to make wicd work for your user, it must be a member
of the 'users' group.
========================================================================

Note: make sure you are in the users group.


  • Make sure you have enabled dbus and wicd services.
ln -s /etc/sv/dbus /var/service
ln -s /etc/sv/wicd /var/service

(Борисав Живановић (Borisav Živanović)) #3

It’s working now! Thanks!