How to get internet connection on VM with void linux


(Aline ) #1

Hello everyone! I am new with void linux and begginer with linux in general. I got a VMware vm with void already installed. I would like to have internet on the vm. Can anyone help me? Preformatted textI have no idea how to even start. Thank you in advance. Aline


#2

Which version did you boot/install? Mostly you just need to enable the dhcpcd service.


(Aline ) #3

Linux version 4.9.87_1


#4

I was asking about which flavour you did boot, like XFCE, LXDE, LXQT, Cinnamon, Enlightement or minimal?


(Aline ) #5

sorry. I would have to guess it is the minimal.


#6

Did you read about the network configuration, especially about dhcp?

https://wiki.voidlinux.eu/Network_Configuration#Dynamic_IP_.28DHCP.29


(Aline ) #7

yes, I read and tried this commands.


#8

Sorry but if you are not going to work here with me I cannot help you.

We don’t magically know what your issue is and you need to learn how to give proper replies in order for someone else to be able to help you.

Either you are more specific and explain exactly what you tried, what happened (including the exact error messages if any) and what you expected to happen there is not much I can do at this point.


(Aline ) #9

Hello! I am very sorry for not being able to give you proper replies. Let me try once again starting from zero.

I received a VM with void already installed. I am actually interested in using this vm to get to know Grafana (which is also already installed). For Grafana, I want to install some plugins and for that I needed internet connection. So I found and read the Network wiki (specially the link you posted). Executing ln -s /etc/sv/dhcpcd /var/service/ didn’t give me any error message.
this is the ip link output

which I must say I cannot explain what does it mean other than showing the available interfaces.
I expected this command to already enable network connection.

Running this command: ln -s /run/runit/supervise.dhcpcd-eth0 /etc/sv/dhcpcd-eth0/supervise
gives me an error message that says that the symbolic link could not be created: the file already exists. I gave it a try with replacing eth0 for ether (considering the ip link output). In this case I didn’t get any error message. I used ping www.google.de to test but I got 100% package loss.

I also tried changing the VM settings for the network adapter: bridged or NAT. With my post I was expecting someone could give me an idea about configuration of network while using a virtual machine and the VMware Player.
Thank you again for the replies.
Aline


#10

What does ip addr say? What VM setup do you have (KVM? VMWare? Other?).

Normally you would want to symlink the full service, not the specific folder.

Like written in the wiki: ln -s /etc/sv/dhcpcd /var/service/

What does sudo sv status dhcpcd say?


(Aline ) #11

ip addr


(for reasons I didn’t feel comfortable in sharing the ip number that shows there)

That was my understanding as well. that symlink for the full service would work.

sudo sv status dhcpcd says:
run: dhcpcd: (pid 630) 878s


#12

Well the service is running and sv status shows that. You have a (valid?) IP address as well.

What happens if you sudo ping google.com? And what happens if you try to ping googles IP sudo ping 216.58.206.14?


(Aline ) #13

Yes, I think the ip is valid because it is the same range as my windows machine.

nothing happens with either ping command or better saying, 100% pkg loss.


#14

Are you sure the WM has enough permissions to communicate with the internet and there is no firewall/sandbox/network blocking?


(Aline ) #15

No, I am not sure about that.

By the way, I forgot to answer you: I mentioned before, I am using VM Ware Player.


#16

I guess its time to debug on the host. Use netstat and alike to find out if the packages actually go through. It most probably is filtered somewhere.


(Aline ) #17

I need some time to check how to do that. Thank you so much for the help so far.


(Aline ) #18

my problem was actually because of proxy authentication that was not being recognized. Thank you AnachronGuy for the support.


#19

Welcome! Please mark the thread as [SOLVED].