Home | News | Download | Packages | Forum | Wiki | Github

How to change xbps to American mirror?


(Evan) #1

Hello,

I have modified the /etc/xbps.d file so that it now says:

repository=http://repo3.voidlinux.eu

Which I thought would make xbps use the American mirror, however sudo xbps-query -L still outputs:

6284 http://repo.voidlinux.eu/current (RSA signed)

What am I doing wrong?

Thanks!


#2

repository=http://repo3.voidlinux.eu/current


(Michael Aldridge) #3

Be aware that repo3 is currently out of date and seems to be out of date quite regularly.


#4

Why would it be? Is it just pulled from the European main repo daily or something?


#5

I’m not sure how often it’s updated, but yes the other repos can be out of date. Especially considering updates happen so frequently on the main repo.


#6

For what it’s worth, I’m on the American west coast (also known as the glorious nation of Cascadia), and latency has never really caused me any problems. There’s an Arch mirror in my city, and I don’t think I’ve noticed a significant difference in download times.


(Aditya Goturu) #7

Many times, alteast for me, the indian mirrors were unusable slow


(J) #8

I ran into problems with changing/adding repositories as well. I now believe my problems were related to unclarity in the documentation. The wiki merely says “Repositories can be declared in a file stored in /etc/xbps.d with a simple format,” giving the impression that the naming of the file could be arbitrary. So I named the file I put there in such a way as I could easily identifiy it, not bothering with things like suffixes. Yet the repository I’d added in that files using the repository= syntax was not being picked up.

Looking over the wiki article again, I noted the example "echo ‘repository=http://my.domain.com/repository’ > /etc/xbps.d/my-remote-repo.conf, and decided perhaps the file naming was not supposed to be totally arbitrary, but that a certain suffix–namely the .conf suffix–was required to be appended to the file name. When I added that suffix to the file I’d created, the system then picked up on the new repository I’d stipulated.


#9

The man pages are 100% better than the wiki, see man xbps.d.
And it would make sense to name the file /etc/xbps.d/00-repository-main.conf, this allows overwriting the file /usr/share/xbps.d/00-repository-main.conf which stores the default repository.


#10

Would anyone else be interested in splitting the cost for a VPS stateside that’s sizeable enough to host a mirror of the Void repo and/or site? I can take care of the sysadmin aspect of the mirror but wouldn’t be able to handle the cost solo. Feel free to comment here or DM me if so.


(Michael Aldridge) #11

@nthrow

There are already 2 stateside official mirrors and at least 2 unofficial mirrors. I think your generous offer may be better served as a donation to the main project to help defer the costs of the buildserver.

If you’re interested in the official mirrors, repo3.voidlinux.eu is Kansas and another mirror is coming online in the next few days. There are two unnofficial repos hosted by Universities. A high speed dedicated mirror is available from the UT Dallas Linux Users Group (https://lug.utdallas.edu/mirror/void/current) and another mirror is available from Georgia Tech via the large mirror.


(Userx) #12

Cascadia is a bioregion and possible proposed country located within the western region of North America. Wikipedia

I’ve never heard of it…


#13

What are the best mirrors to use in North America? Are the other repos still often out of date?


(Michael Aldridge) #14

The repos are kept in pretty tight sync, but if you want a fast mirror I’d look for one close to you.


#15

I’ve been using the UT-Dallas one, and that seems to work well. (I think that’s the one you’re associated with, no?)


(Michael Aldridge) #16

I was associated with it for some time, but it has since been handed off to a new ops group. I am one of a few general contacts for the mirror infrastructure currently.


#17

the repo3 LA mirror has been down for a few days.


#18

Aha, that explains why I couldn’t sync/install :slight_smile: Is there anything we can do to help?

On a related note, would it be possible to have xbps use multiple repos with a fallback? I tried just putting multiple repo= lines but that doesn’t seem to work (sync eventually works, but trying to install packages only tries one repo and fails). I think the best way to do this would be to sync package indexes from all known repos and pull packages from any/all that claim to have it. Part of the idea being that I could then keep a mirror of just some packages without having to mirror the whole thing, and it would still just work and fall back as needed.


(Michael Aldridge) #19

Please see Ongoing Infrastructure Work & Forum Woes

Multiple mirrors in fallback mode is not currently supported, but it is on the list of features for a future version.


#22

I’ve been updating through the utdallas mirror mentioned by @maldridge for quite some time, but now I notice it’s been out of date for at least a week.

At the time of this writing (Jan 19 2018) their index says, for instance, that the latest kernel package is 4.14.13_1 uploaded Jan 12, whereas in the main repo the latest is 4.14.14_1, uploaded Jan 19.

Does anyone know whether this happens frequently? I’ve never compared the two repos before; this time I noticed because it’d been longer than usual since I’d gotten any updates.

I’ve switched back to main temporarily, but UTD sure is faster (I’m in the US)…