Home | News | Download | Packages | Forum | Wiki | Github

How can I make Void Linux run a DE by default at boot?


I just installed budgie DE onto void, but I need to have it run at boot like a pre-installed DE. how can I do this?

How do I run a desktop environment automatically after login?
(rakor) #3

You mean you want it to start without beeing prompted for a user and password?

You will need a Displaymanager (DM) for doing this. https://wiki.voidlinux.eu/Display_manager

Maybe you are searching nodm https://wiki.voidlinux.eu/Nodm


if I use Nodm will it automatically boot into Budgie? Or should i use a DM?

(rakor) #5

Read what nodm does. If it fits your needs you are fine.
If you want to have a loginprompt you want to have a real DM


So if I install Nodm, then it’ll automatically boot to budgie?

(rakor) #7

Read what nodm does. If it fits your needs you are fine.
If you want to have a loginprompt you want to have a real DM

We are trapped in a loop…

You have to configure it… But if you read what it does, I think will fit your needs.


Ok, thanks! I just installed Nodm. how do I modify Nodm.conf ?

(rakor) #9

What exactly do you mean? I don’t use nodm myself, so I don’t know the syntax.
Have you tried the steps in: https://wiki.voidlinux.eu/Nodm


I’m up to this step:

After installing nodm, you should modify the /etc/nodm.conf file.
but I don’t know how to do that without a “full” UI.

(Erin) #11

man vi vi is a command line editor.

An Internet search on what to edit in /etc/nodm.conf may also help you.


Its not hat I don’t know what to change, but rather that I don’t know how to change it.

(rakor) #13

You need an editor. If you are not familar with the vi(m) it’s not the best time to start using it, but I don’t know which easy editors are in xbps.
If you have an easy cli-editor choose it. If not here are the steps for vim (which must be installed first):

  • Open the file:

vim /etc/nodm.conf

  • switch from command-mode to insertmode by pressing the key i
  • make your changes to the file
  • Switch back to command-mode by pressing the key esc
  • save and exit the file by typing :x and press Enter.

Now you should have changed your file.


when I open up the file in vim, it just shows a bunch of purple lines

(rakor) #15

ok I can’t help any further without seeing what you mean.

Other solutions: try another editor or if you feel comfortable on a GUI, start a livecd, mount your device end edit your file (but I think this is not adequate for editing a textfile at all)


It doesn’t show any text.
All it shows is purple lines on the far left.


you might be better off just using LXDM and setting it to autologin(via it’s gui tool: lxdm-config)


will LXDM work with budgie?


i’d be surprised if it doesn’t…
it should find any DE that has a .desktop file in /usr/share/xsessions

btw, console editors for beginners: nano, or mcedit(part of mc)

(Gus Fun) #20

Do you know the difference between console and terminal? What terminal are you using?

Forget vi, that is a system on its own to learn.
Use nano, a simple text editor with the commands described on the bottom.

with root privileges or sudo type
nano /etc/nodm.conf


Enable the service so it will be started on boot.

sudo ln -s /etc/sv/nodm /var/service