Home | News | Download | Packages | Forum | Wiki | Github

Having Difficulty Installing


(Masato the Empty) #25

I would doubt that the iso is an issue. Unless @bendurham441 has loads of bandwidth and downloading a 500MB ISO is a snap, I’d hold off on that. (Of course, one could download it on another system while following other leads, that’s not a terrible idea).

Getting messages about files not being found… I suspect you’re getting them at the stages where something is being performed on the target partition, which relies on data that should be on that partition.

That would mean things aren’t getting copied over.

Now, I actually do recall something like this happening to me, when I was playing with things for documentation purposes a couple of months ago.

I had a VM, and I was using a 2.5-inch IDE HDD on a USB bridge, which I’d given to the VM. I did run into various things failing, and they seemed to be due to missing components on the target partition. Suspecting the disk was wonky, I eventually used a virtual disk (file on my host system) and the problems ceased.

I’ve yet to get back to testing that disk (it’s just one of a handful of spares I keep lying around with no good use for), and I don’t know whether the disk itself is to blame, or whether something just wasn’t being handled correctly. Having been on a USB2-IDE bridge, the OS doesn’t get to talk directly to the disk in the same way as it would were it on a native bus…

Things like cache flushing/delayed-write problems come to mind; however, I’d normally expect failures in that area to cause the system to detect an error; in this case, that doesn’t appear to occur.

If anyone has any experience with those sorts of problems, they might have information worth exploring. Maybe some settings that can be played with, that are available via commands on the live image (mount options being the likeliest)?


(Alex) #26

@masato to the rescue!
Ye, maybe I carried away a bit to far. Trying to help with my limited knowledge, as much as I could, in a situation I felt I maybe could be of help.

Sorry if I said some thing wrong.
And thanks for the correction, bud! =)


(Masato the Empty) #27

Well it wasn’t something to totally rule out at this point, just to hold off until later, since it’s rather inconvenient.

Whenever troubleshooting, unless you’ve got an overriding reason, you want to check the easy/fast things first. Going out of your way for uncertain reasons isn’t as likely to pay off (it might every once in a while).

Similarly, going out of process to work around something which you haven’t comfirned to be the issue tends to make things harder, and can obsure the root cause even more.

So has anybody ever had problems with files failing to get written to disk, and not getting notified?


(Alex) #28

extF … could it be file-system related?


(Masato the Empty) #30

I find that doubtful. He’s got files not found, which means they’re not successfully recorded to the disk. An experimental FS maybe, but not EXT4 (or btrfs either at this point in time).

I always do it that way too; I think there’s an anon user on the disc, and that one has to sudo. Without that, you won’t get that far; I haven’t looked to see if it checks, but if not, then non-root users would error out on mounting, since nonroot can’t do arbtrary mounts.

Looking at the script, the following actions depend on certain data being already present on the target partition.

  • set_locale() (just glib systems I think; it only does anything when it finds the locales system)
  • set_timezone() - it edits the rc.conf that’s already copied to the target.
  • set_rootpassword() - runs chpasswd against the database on the target
  • set_useraccount() - runs useradd and chpasswd against the target
  • set_bootloader() - chroots and runs grub-install from there
  • install_packages() I think - should be editing a package database on the target…

there are also a couple of chroot operations in the main routine.

So far, it looks like @bendurham441 has had failures on set_bootloader, and on either set_useraccount() or the part early on in the main routine where it removes the live user from the pwdb (which was supposed to have been copied to the target).

That really seems to say files aren’t getting copied… but again, why that doesn’t create an immediate failure is the hard part…


(Ben Durham) #32

Sorry about that. That was my first day so there was a limit to how many posts/replies that I could do. So, here is what is new:

I tried it on another laptop, and it worked absolutely fine, so it definetly isn’t something wrong with the ISO. A local install hasn’t worked either (and that is what I will be doing from this point on (I don’t know why I thought that I had to do a net install). I think that I need to do a manual install. Can someone point me towards the path to the script, so I can just follow along and see where it goes wrong?

By the way, thank you all for the help that you have given me so far. Also, I’m glad to see you back @cr6!


(Alex) #33

“Script”?
Maybe you think more like “Walk through”?
Correct me if I am wrong.

[EDIT]
By the way… your “forum-privileges” will be soon-in-time escalated, after you made a number of posts/replies, used different forum-functions, etc.

Example, you will be given “Badges” when making things first time.
-First post
-First like
-First link
Etc.

I suggest you also have a look at some of those functions and get familiar with them. :slight_smile:

[EDIT 2]
I have no idea about those scripts, we will have to wait for @masato ?
To edit your post, you click the Pen-Symbol:


(Ben Durham) #34

I mean the script that is run by the void installer.


(Ben Durham) #36

I am using the “void-live-x86_64-20160420.iso” because I intend to use a window manager that doesn’t come standard. I have tried void-installer both with and without root priveledges.

I’ll try the i686 just for the heck of it.

EDIT: No difference with the i686 image. I will try to manually install grub next, instead of having it done through the script.

EDIT 2: I am having some difficulty installing the boot loader manually. Can someone correct me:

  • I do the installation manually, but check the option of installing the boot loader after manually.
  • I make a directory
  • I mount the root partition of the installation to that directory
  • I chroot into that directory
  • I use the following commands to install grub:

-grub-install -target=i386-pc /dev/sda

  • grub-mkconfig -o /boot/grub/grub.cfg

I get the following error: /usr/bin/grub-probe: error: cannot find a device for / (is /dev/mounted?).


(Ben Durham) #37

Well, I hate to be a quitter, but I just think I need to be done with this, at least for now. I’ll just use some other distro for the moment and come back to this, because I just don’t know what to do anymore. Anyway, I just want to thank you all for all the help and suggestions that you have provided, but I think I am just going to move on for the moment.


(Alex) #38

Aaw… ok =C
But I hope you will be back sooner or later.
Cheers! :slight_smile:


(Masato the Empty) #39

Wow, that’s rather uncomfortable…

But I was stumped on this one. It appeared that files were not successfully copied to the target disk. How many / which files, we never did see as we didn’t get as far as comparing the contents of the live image to that of the target disk. Not to mention why

I think I’m decent with shell scripts if I am able to run through what it is doing. Void installer is pretty easy to follow.

One of my main methods for troubleshooting a script is rather clunky; it involves inserting debug-like comments at various stages to output to either a file or stdout to see exactly what part of the code fails. Of course, first I have to duplicate the issue and I was unable to do so last night…

I actually find it more convenient to do the local install for a working system, then do the big upgrade when I’m ready. (at least for Void since our non-DE live image is a good start for a somewhat minimal system… For Debian, I would do netinstalls since there was an image just for that, and it was the smallest with the fewest packages built in.)

Each way has pros and cons but both are suitable for most cases I think…

I did a swapless system before. When I switched to Void, I started with such a massive HDD that I decided to go ahead and keep a swap partition around, It’e never a bad idea if you don’t have to economize disk space. The amount of space is insignificant in my case. I encrypt it with a random key at each boot and I don’t hibernate a desktop (I use the nohibernate kernel cmdline, so it the system doesn’t see it as an option).

To my knowledge, it’s never been used. No terrible loss.

I forgot to mention bind mounting the pseudo-filesystems in the target (sys,proc/dev) and that’s probably the reason for this error. That’s also in the manual walkthroughs, but I did suggest you only needed to look at the grub parts… as they say, my bad.

@bendurham441 Anyway, as you can hopefully see, you’re welcome back any time you wish to tackle this again.


(Masato the Empty) #41

huh, that’s weird. Fixed. (it was actually a comment I put somewhere else in the post and decided to leave out… some sort of clipboard mixup perhaps, or I accidentally pasted…)


(Ben Durham) #43

Ok then! I shall tell you if I have any success with other distros. I don’t really know where to go from here. I feel like I am not quite ready for gentoo, but I might try it anyway :wink:


#44

How about Arch?


(Ben Durham) #45

I have tried (and I do like) arch. This is not my main machine, and I just want to try something new. Anyway, I have already started installing gentoo.