Home | News | Download | Packages | Forum | Wiki | Github

Having Difficulty Installing


(Ben Durham) #1

Hello there. I am looking to start using void linux, but I am having an issue installing void. I am using an x86-64 image and everything goes fine throughout installation until it gets to the part where it installs the boot loader. I have retried several times now, but I get the same issue:

ERROR: failed to install GRUB to /dev/sda

tty8 shows the following output:

chroot: failed to run command 'grub-install': no such file or directory

What should I do? Thank you for any responses.


(Masato the Empty) #2

I’m drawing a blank as to why you’d have that particular failure. It means that grub-install isn’t found when chroot switches to the target partition. But I don’t think the installer should even get that far without having successfully copied over everything (that’s on an install from CD; network install I’m less familiar with, but it uses xbps to pull the packages from the internet, which I’d expect would fail the whole process on any error).

So you’ll probably need to do some poking around when it fails to see the condition of things. You’ll want to remount whatever partition was your target root, and see if all the necessary commands are in there (/usr/bin/grub-install). In fact, everything from the Live OS should be copied there, with the exception of things that you directed to other partitions (such as /var and /home).

If somehow everything DID get copied to the target partitions then you could instead install grub manually. The installer unmounts the target after success or failure, so you’ll have to remount it yourself. For information on manually installing grub, see some of the walkthroughs on the wiki for manual/advanced/chroot installs; you’re probably just concerned with the parts on grub setup at this point.

Otherwise some details that may shed some light on your issue would include what you did at the “partition” and “filesystems” steps, compared to what hardware is on your system. Before going through with the install, you can select settings on the bottom menu (left and right arrows) and see the summary there.

It may also be relevant whether you’re installing in legacy BIOS mode or UEFI mode.


(Alex) #4

Just a wild thought…
Did you check the downloaded ISO with checksum/hash? Could this type of issue be due to errors during the download/burn?
(Just to rule this one out.)

Oh… and also, welcome to the Void! =D


(Ben Durham) #5

I did not do so. That is what I will try first. Also, thank you!


(Ben Durham) #6

Yes, /dev/sda is my main HDD. I have verified that with lsblk. There is no other OS on this device.


(Ben Durham) #7

To be clear, I am installing in BIOS mode. I think I will first try to download another iso and verify the checksums. I really should get into the habit of doing that. If I still encounter this error, I will look closely to see if other things went wrong during the installation.


(Ben Durham) #8

I think I need to take a step back here. I think I might have done the partitioning incorrectly. Is there any chance that I could get some help with that? I thought I knew what I was doing with my experience with partitioning from a few arch installs, but I think I did it wrong (then again, I have never installed linux on a BIOS system). I know that I need a root, swap, and boot, but what flags do I need, if any.


(Ben Durham) #10

Ok. Thank you. Maybe the boot partition was somehow messing with things(?) I will try with just a root partition and swap then.


#12

Don’t listen to cr6, follow the instructions fo the installer there is a large message before partitioning, that you need a partition that is flagged as bootable with BIOS systems.
Depending on the partition table type you choose you need more partitions.


(Alex) #14

@cr6 @Duncaen
Disagreements, disappointments and hurt feelings are part of this life.
But I was very sad when I read last two comments.
I truly hope that we can all get along.
:disappointed:


#15

I had this error, and I wrote down what I did at the time for future reference:
The first attempt on this install didn’t work as I mistakenly chose GPT not DOS for the disk after having previously totally wiped it with badblocks -ws and this GPT setting was then retained causing subsequent installation attempts to fail as there was no option to change it in cfdisks.
GPT isn’t needed for older BIOS installs, it’s for TB sized disks and it needs an extra partition for the gpt table that I hadn’t created. It could have worked then but would have wasted a little disk space for no benefit to me that I know of.
Error! Failed to install Grub
Check /dev/tty8 for errors
(Ctrl Alt F8 to see, Ctrl Alt F7 - could be F1 for a terminal install - to return to the original tty)
I ran void-installer again, but there was no install menu option to switch from gpt to dos after the selection was made. I deleted the partitions made earlier and shut down to try again later after more online research.

So, now to install and correct my earlier error:

Boot CD using RAM option - I had 1GB RAM installed.
At start of XFCE desktop select default config. Then there’s a terminal icon on the bottom panel.

Follow the onscreen instructions and make the usual bunch of installer setup selections - keyboard, locale, timezone etc.
Didn’t bother setting up a network connection as I’m installing from the CD image.
Go through menus, cfdisk still says it’s a GPT disk and won’t offer to change it, when unset there had been a choice in the menu. So I used the interactive fdisk program from the live image:
shift ctrl t - open a new tab in XFCE terminal.
$ sudo fdisk /dev/sda
m (for help)
o
w
That changed it to DOS.
Partition drive as required:
/dev/sda1 primary bootable 26.9G 83 Linux
/dev/sda2 primary not bootable 1.1G 82 Linux swap / Solaris
Write to disk, type yes. Quit.

Filesystems
/dev/sda1 mount / fs = ext4
/dev/sda2 linux swap
Back to go back to main menu
Select install, about 5 minutes later it had installed Void successfully this time.

Perhaps your error is different though. On my latest install which I’m using now, I am using BTRFS not EXT4.


(Ben Durham) #16

Well, I have concluded that partitioning is not the problem. Using the following paritioning (shown below), the install process did get farther than before, but it is giving similar errors for different things. What I mean is that I see several things like “unable to do X because X is not found” and stuff like that. The same is true for user creation: “user not found.” I honestly am at a loss about what to do now.

Partitioning:

/dev/sda1 4GB Swap
/dev/sda2 465 GB ext4 mounted as “/”

EDIT: I meant ext4. Sorry for the confusion.


(Alex) #17

Ok.
Do you have an other machine with an empty disk to test installation on?

For example. I have successfully installed Void (x64, Cinnamon) on several computers. Then I tried on my Asus laptop. Things turned ugly. Me and helping guys on this forum found out there is a kernel bug that kinda can not be fixed. (long story short)

So, just to rule out hardware-related issue, if you can, try to install on an other machine? (If you can)


(Ben Durham) #18

As a matter of fact I do. I happen to have stumbled across several low-spec laptops that will serve such a purpose well.


(Alex) #19

Oh… here is the thread I was talking about… Warning, long read :wink:


(Ben Durham) #20

Now I have problems on top of problems. With this laptop, I can’t even get the network working. For both the wired and wireless networking, I get errors saying DHCP request failed and nothing helpful on tty8.


(Alex) #21

Oh… are you trying to do a NET-install?


(Ben Durham) #22

Yes. On the first laptop I was able to get it to work fine with ethernet.


(Alex) #23

I see.
I had a similar problem with one of my other laptops (HP mini had a wifi module that was not working with void)

Also. I am still fresh in Linux world and this far have not tried to do a NET install.

Why not start with a full blown flavour-iso? =) I mean, just to test things out.
[EDIT] hence, selecting Local source and not net.


(Ben Durham) #24

I will definetly try that. I have to go now for a while, but I will do so as soon as I can. I will reply as soon as possible.