Home | News | Download | Packages | Forum | Wiki | Github

French keyboard layout X problem?


#1

I have read the Void wiki to configure my keyboard :

[https://wiki.voidlinux.eu/Post_Installation]

I put ‘KEYMAP=fr’ in the file ‘/etc/rc.conf’

I edit the file ‘.xinitrc’ in my "Home directory’ and I put ‘setxkbmap fr’ in it.

But when my Xfce session starts I got the US keyboard layout instead ! :frowning:

~ ~ ~ ~
According to the Xorg website :
http://www.x.org/releases/X11R7.6/doc/xorg-docs/input/XKB-Config.html

I find this solution to have my keyboard in French !

create the file ‘/etc/X11/xorg.conf.d/90-custom-kbd.conf’ with this settings:

Section "InputClass"
Identifier "keyboard defaults"
MatchIsKeyboard "on"
Option “XkbModel” "pc105"
Option “XkbLayout” "fr"
Option “XKbOptions” ""
EndSection


Running a DE with x86_64-musl and language
#2

Did you install setxkbmap its not part of xorg-minimal?


#3

Of course I have installed setxkbmap with the full-Xorg but “setxkbmap fr” don’t works when it is set in .xinitrc file!


#4

Well if you put something else in xinitrc, does it work with that then? :slight_smile:


#5

As I said before the setting “setxkbmap fr” in the file .xinitrc DON’T WORKS.

But according to this page:

If I put “setxkbmap fr” in a new file .profile IT WORKS!!


#6

Ok, ok. I was just curious of why it did not work.
If The language file “fr” was in the wrong directory, or if xinit wasn’t loaded at start, or if maybe there was a syntax error like missing a “exec” and/or a “&” at the end…
But I guess the problem is already solved then and all is good.


#7

Shampoo to clarify the situation can you show me your .xinitrc file in your Home directory please ?


#8

Do you mean it’s “exec setxkbmap fr” or “setxkbmap fr &” ??


#9

i don’t know if there is any point in that since i don’t use a login manager, and i set my keyboard in /etc/X11/xorg.config.d/30-keyboard (i am the only one who uses my computer)
but here you go anyway.

exec startfluxbox

and thats it. startfluxbox on the other hand starts a script “~/.fluxbox/startup”, that has

exec fbsetbg -l & exec compton & exec ~/.config/conky/time_date/startconky & exec ~/.config/conky/systeminfo/startconky & exec ~/.config/conky/downloadbox/startconky & exec volumeicon & exec fluxbox

in it


#10

Ok.

For me it’s the same situation: I am the only one who use my computer.

And obviously all the people I know speak my language, so… no need for multiple configurations of keymap/layout…


(Pedro Narciso García Revington) #11

Hi,
In my .xinitrc I’ve got

setxkbmap -layout us -variant dvp -option compose:102 -option ctrl:nocaps
xrdb -merge .Xresources

exec i3

AFAIK there is no reason to send setxkbmap to background. Also, you can check what is the loaded keyboard with
setxkbmap -query


#12

:wrench:
The problem was because I used LightDM as display manager… and LightDM don’t look at ~/.xinitrc file.

This is why my keyboard was not in French in the Xfce session.

~/.xinitrc file can be used by “xinit” or “startx” commands.

This is what I do today, I don’t use anymore LightDM or any other display manager.

https://wiki.archlinux.org/index.php/Xprofile

https://wiki.archlinux.org/index.php/Xinit

http://daemonforums.org/showthread.php?t=6859


[ Solved ] Void musl, some beginner questions?
[Solved] Unable to mount drives and set emblems using file managers, despite gvfs being installed
(David) #13

Just to make this more complete, this is also happening with the installer for the MATE version based on glibc, it’s a general problem with the installer on this flavour.

It doesn’t matter which keymap you pick in the installer, as soon as you reboot and get to the login screen, you’re scre*** if, for instance, you picked a strong password for your account using symbols, as you are stuck with the US keymap on the login screen and most likely you can’t/don’t know how to type those symbols.

After you log in, the US keymap is still in use until you get to the Keyboard prefs editor or something else to solve the problem.

The funny thing is, on the init screen I can clearly see the message

Setting keymap to "es"

but just like the cake, this is a lie! :grinning:


Introduction & wiki
#14

You are possibly confusing two things: the console keymap (that you selected in the installer), and the Xorg keymap (which is not set by the installer).


(David) #15

Maybe, but the US keymap is the current one everywhere until I change it in the prefs, then immediately the switch applies everywhere too. From the perspective of the average Joe (like yours truly) the installer (or whatever is responsible for this) is buggy.


#16

With all respect, the installer is not buggy…
What’s your keymap if you login directly into the console?
For your desktop environment you have to set the keymap within xorg.
I’ve also found this confusing and annoying the first time, but hey… It’s how it works right now.
Annoying, yes. Something to correct in the future, maybe. Buggy, no.

One thing I really like about Void is flexibility. I like to be able to choose all components of my system. For example, I don’t like login managers (they are just another layer, only useful if your PC has several users), I like my keymap properly set, but I want everything else in English. Void gives me the flexibility to do this and much, much more the way I want to from start.
My first linux system was also Linux Mint. I actually have Peppermint in my main PC. Why Peppermint and not Mint? Because Peppermint doesn’t come with everything installed. I found myself removing stuff from Mint more offen then installing.