Home | News | Download | Packages | Forum | Wiki | Github

Failing installation on efi system


#1

Hey! I have a problem with installing Void on my T430. I get this error:

“ERROR: failed to install GRUB to /dev/sda! Check /dev/tty8 for error.”

I tried to play in bios with settings but nothing worked. I thought it’s because i forgot to set EFI partition and setting it with bootable flag but it’s not it, i can’t check if it has bootable flag because cfdisc is not showing any indications.
I tired to access /dev/tty8 but i can’t, i get messege that this file doesn’t exist.

Please help me because i try to solve it and google this problem for over 6 hours now. ;_;


#2

/dev/tty8 is another console, you can switch to it with CTRL+ALT+F8, and CTRL+ALT+F1 to go back to the first one.


(Masato the Empty) #3

assuming you used gpt partition layout, there is no bootable flag. The concept doens’t exist in UEFI. Instead, UEFI can read boot files on a FAT12/16/32 filesystem.

May I ask which installation procedure you used?
I’d recommend taking a look at this article if you have not already. Especially the part about checking whether you’re booted in EFI mode. Installing EFI grub is problematic if you’re doing it from a legacy environment (it can be done manually, but you may also have to manually add your Linux install to the grub menu as os-prober doesn’t seem to detect EFI installs from legacy boots, and vice versa.

Note that you can either start over with the install, or you can use the grub CD to rescue boot into your installed system, provided that only grub installation failed. (if you can boot the installed root, then you can make the necessary fixes from within the running OS, such as. mounting ESP, installing grub etc).


#4

The whole installation fails. It turns out i wasn’t in Uefi mode but i can’t boot with USB, but i guess it’s problem related to my laptop rather than Void. ;_;


#5
  • I can’t boot with usb in EFI mode.

(Masato the Empty) #6

Well if you can find a way to boot USB in UEFI mode, then there will still be hope. This should really be available on most modern systems. Otherwise, you’d be unable to ever reinstall the operating system.
Double-check your UEFI setup utility, or see if you can get a boot menu (it’s sometimes the F11 key).


#7

Can you boot with a CD/DVD?

My Toshiba Sattellite has this problem - I can’t remember what the actual issue was though. It will always boot from a CD or DVD though - once the Secure Boot is disabled in the BIOS.