Home | News | Download | Packages | Forum | Wiki | Github

ERROR: xbps-0.51_20: [unpack] INSTALL


Good Afternoon
I’ve just joined the forum so I’ll give a little preamble. I’ve been using Void as a ‘backup’ OS on my ‘new’ laptop (second-hand Dell 6430) - only backup because it isn’t mainstream & I’m not linux proficient (though I do try. What I love about Void is its lightweight, lightening fast & systemd free :smiley:
Up till now I have had relively few issues & non that I havent been able to resolve myself - till now.
Basically during recent updates I’ve installed libxbps-0.51_20 but cannot install xbps-0.51_20 & am still on xbps-0.51_19. This is what I get:

xbps-install -Su

[*] Updating `https://repo.voidlinux.eu/current/x86_64-repodata’ …

Name Action Version New version Download size
xbps update 0.51_19 0.51_20 81KB

Size to download: 81KB
Size required on disk: 81KB
Free space on disk: 5343MB

Do you want to continue? [Y/n] y

[*] Downloading binary packages
xbps-0.51_20.x86_64.xbps: 81KB [avg rate: 1211MB/s]
xbps-0.51_20.x86_64.xbps.sig: 512B [avg rate: 11MB/s]

[*] Verifying package integrity
xbps-0.51_20: verifying RSA signature…

[*] Running transaction tasks
xbps-0.51_19: updating to 0.51_20 …
xbps-0.51_20: unpacking …
ERROR: xbps-0.51_20: [unpack] INSTALL script failed to execute pre ACTION: Permission denied
ERROR: xbps-0.51_20: [unpack] failed to unpack files from archive: Permission denied

Also I get this checking for errors in all installed packages:

xbps-pkgdb -a

ERROR: xbps: dependency not satisfied: libxbps-0.51_19

I can still use xbps & it seems to be performing ok but obviously I would like to resolve this. Unfortuately I made the mistake of purging the cache so libxbps-0.51_19 is not on my machine & this is what I get if I try to force downgrade:

xbps-install -Sf xbps-0.51_19

[*] Updating `https://repo.voidlinux.eu/current/x86_64-repodata’ …
Unable to locate ‘xbps-0.51_19’ in repository pool.


xbps-install -Sf libxbps-0.51_19

[*] Updating `https://repo.voidlinux.eu/current/x86_64-repodata’ …
Unable to locate ‘libxbps-0.51_19’ in repository pool.

Any pointers please chaps?

Automake broken? [SOLVED]
(Edmond Dantes ) #2

Hi, If you have /var on a separate partition, try removing any ro, nosuid,noxec mount option in fstab and mount it with defaults (optionally noatime) instead.


No everything is on the one partition - I do have a seperate data partition on a seperate drive with symlinks to it though. Because my OS is on an SSD I have my tmpfs loaded into RAM & I recently secured it with nosuid,nodev,noexec, so it is now set as:

/tmp tmpfs defaults,noatime,nosuid,nodev,noexec,mode=1777 0 0

However I doubt that thatb is causing an issue - just I wish I hadnt been so quick in purging my cache :slightly_frowning_face:


I think having your /tmp mounted with noexec is exactly the problem, see e.g. this topic.


Cheers bluemoon you were absolutely correct. :wink:
After reading the post you linked to I removed the noexec option (as it isn’t supported - & after reading up about atime amended noatime to relatime while I was about it). Re-synced & updated - no issues.
I did search the forum (& Duck Duck Go) for this issue & it didnt turn up this answer (not that I saw anyway) but thanks very much bluemoon for sorting it for me


It’s hard to find an answer when you don’t even really know what the question is. :wink:


Hmm :face_with_raised_eyebrow:- I did make a disclaimer in my OP

And to search I used the error output ?? But hey cheers for your help any road.