Home | News | Download | Packages | Forum | Wiki | Github

Dwarf Fortress help? [SOLVED]


(Xlaits Xavier) #1

So, trying to run Dwarf Fortress today. Fresh download, the only difference is that I’m forcing it into cli mode.

On my very first run, I get the following error:

./libs/Dwarf_Fortress: 1: ./libs/Dwarf_Fortress: Syntax error: ")" unexpected

Some digging around shows that I need to install the latest java, and after installing both openjdk and openjdk-jre, I still get those errors. Any ideas?

After some more digging around, I have found that it seems that there is no package for gtk in void. Is this true, or am I being blind again?


(Xlaits Xavier) #2

Well, I’ve done more research, even asked around on reddit. Got a pretty decent response, and now I have a new error.

libpng error: bad parameters to zlib

It’s saying it can’t find an image that I know is there.


(oliver) #3

Did you take a look here? http://dwarffortresswiki.org/index.php/DF2014:Installation#Fix_1:_Preload_zlib


(Xlaits Xavier) #4

D’oh! I missed that! Thank you!