Home | News | Download | Packages | Forum | Wiki | Github

Did I break xbps?


#1

do I get to keep both pieces… :smiley:

[chris@xps-void ~]$ sudo xbps-install -Su
[*] Updating `https://repo.voidlinux.eu/current/x86_64-repodata' ...
[*] Updating `https://repo.voidlinux.eu/current/multilib/nonfree/x86_64-repodata' ...
[*] Updating `https://repo.voidlinux.eu/current/multilib/x86_64-repodata' ...
[*] Updating `https://repo.voidlinux.eu/current/nonfree/x86_64-repodata' ...
libreoffice-5.4.2.2_1: broken, unresolvable shlib `libpoppler.so.71'
Transaction aborted due to unresolved shlibs.
[chris@xps-void ~]$ sudo xbps-query -s poppler
[*] epdfview-0.1.8_8       Lightweight PDF viewer using Poppler and GTK+
[*] poppler-0.60.1_2       PDF rendering library
[*] poppler-data-0.4.8_1   Encoding data for the poppler PDF rendering library
[*] poppler-glib-0.60.1_2  PDF rendering library - GLib bindings
[*] poppler-utils-0.60.1_2 PDF rendering library - utilities
[chris@xps-void ~]$ sudo xbps-query -f poppler
/usr/lib/libpoppler.so.71.0.0
/usr/lib/libpoppler.so.71 -> /usr/lib/libpoppler.so.71.0.0
[chris@xps-void ~]$ ls /usr/lib/libpopp*
/usr/lib/libpoppler-glib.so.8      /usr/lib/libpoppler.so.71
/usr/lib/libpoppler-glib.so.8.9.0  /usr/lib/libpoppler.so.71.0.0

or is this some kind of issue with the repo itself?


(John Peach) #2

libreoffice is being rebuilt: https://build.voidlinux.eu/waterfall

There is another thread about xbps holds not working.


#3

kinda begs the question, if I want to upgrade all packages except this one - how would I do it?


#4

Using xbps-pkgdb

ex:
# xbps-pkgdb -m hold <package>

Change hold to unhold if you want to update your package.

Please see this great post https://www.voidlinux.eu/usage/xbps/ :wink:


#5

completely missed that one… thanks