DELL INTEL XEON E3-1200 v2/3rd gen Low resolution [partially patched]


(Gus Fun) #1

Hi, my void has been running trouble free for weeks now, not much to complaint about it, I run openbox without a DM and really enjoying it. So I threw a challenge into my boring trouble free experience and switched the disk into a much newer piece of hw, described below.
I looked for any specific firmware, not much. I messed with grub resolution and what gfx mode it passes to kernel, I tried text and keep which usually recommended, no change. It is functional otherwise but going from 1920 to 1024 is like going 20 years back to pre-pentium era.
LXrandr only list 4 resolutions and auto and maximum is 1024. This is the same monitor that was used before with i915 gfx which worked fine.

00:00.0 Host bridge: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor DRAM Controller (rev 09)
00:02.0 VGA compatible controller: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor Graphics Controller (rev 09)
00:14.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04)
00:16.0 Communication controller: Intel Corporation 7 Series/C216 Chipset Family MEI Controller #1 (rev 04)
00:19.0 Ethernet controller: Intel Corporation 82579LM Gigabit Network Connection (rev 04)
00:1a.0 USB controller: Intel Corporation 7 Series/C216 Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 7 Series/C216 Chipset Family High Definition Audio Controller (rev 04)
00:1d.0 USB controller: Intel Corporation 7 Series/C216 Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation Q77 Express Chipset LPC Controller (rev 04)
00:1f.2 IDE interface: Intel Corporation 7 Series/C210 Series Chipset Family 4-port SATA Controller [IDE mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 7 Series/C216 Chipset Family SMBus Controller (rev 04)
00:1f.5 IDE interface: Intel Corporation 7 Series/C210 Series Chipset Family 2-port SATA Controller [IDE mode] (rev 04)

#2

You mean modifying GRUB_GFXMODE settings in /etc/default/grub ?
Which settings did you try ?
Just found :small_orange_diamond: this page :small_orange_diamond: related to the same kind of issue…


Looking at the Arch wiki, there’s something called 915resolution hack


(Masato the Empty) #3

Could be a couple of things.

  • grub is messing up your firmware’s graphics capabilities (interactions between grub gfx settings and firmware, and maybe booted kernel)
  • problem with the chip getting your monitor’s EDID

Before looking into the EDID, you should have grub do text mode. I’ve heard of it causing problems, though not ones like this. But lets keep it out of the mix. (see this thread - the solution ends up being something I’ve seen before from a conversation I had a while back in the Void IRC)

OK, for the EDID - first you want to locate it. That’s going to be at
/sys/class/drm/card<#>/card<#>-<input>/edid
For example, on my Ivy Bridge (same lspci ID on the iGPU as yours) connected via DVI, my monitor EDID ends up here:
/sys/class/drm/card0/card0-HDMI-A-1/edid

If you install the read-edid package, you can pipe that file into the parse-edid and get some useful info about your monitor, including vendor/model info, EDID version and some timing info (but not necessarily what you’re looking for; mine is EDID v1.3, and that program doesn’t tell me the native resolution).

If you’re not even getting EDID info, then there’s a problem with the system getting that. I believe causes could include:

  • monitor defect causing EDID to not properly get sent on that particular input
  • cable defect causing the same
    • these are especially relevant if you’re not using the same connections on this new system that you used on your old
  • If you’re sending the signal through some sort of converter (say HDMI on mobo to VGA on monitor) then that could interfere (I’d think something well-made would translate that but what do I know?)

If you do have EDID information, then the fun part is parsing a hexdump to see if it contains the correct timing/resolutions (google is your friend. I just looked up info for my own, version 1.3)


(Gus Fun) #4

Ok, I tried this hack at the linux line in grub and now with lxrandr I adjusted the resolution and it is fine while on X, but now my console went really low, which means that I miss the bottom 10-15 lines and I have to keep hitting return for them to appear on screen. So I am logging into console blind-folded.

It seems as the driver is still i915, while I understand that this is not i915, the previous hardware was, or is this a general class of intel graphics?

So this is partially solved but just now I noticed on a different installation the gfx are 1920x1080 but lxrandr’s options go only up to 1024. Void’s lxrandr does show the whole list of all resolutions appropriate for the screen.

hwinfo doesn’t exist in void so I used lshw

VGA compatible controller
/0/100/2


product: Xeon E3-1200 v2/3rd Gen Core processor Graphics Controller [8086:162]
vendor: Intel Corporation [8086]
bus info: pci@0000:00:02.0
version: 09
width: 64 bits
clock: 33MHz
capabilities:
	Message Signalled Interrupts,
	Power Management,
	vga_controller,
	bus mastering,
	PCI capabilities listing,
	extension ROM
configuration:
	driver: i915
	latency: 0
resources:
	irq: 28
	memory: f7800000-f7bfffff
	memory: e0000000-efffffff
	ioport: f000(size=64)
	memory: c0000-dffff

(Gus Fun) #5
lrwxrwxrwx  1 root root    0 Feb 13 12:38 renderD128 -> ../../devices/pci0000:00/0000:00:02.0/drm/renderD128
lrwxrwxrwx  1 root root    0 Feb 13 12:38 card0-VGA-1 -> ../../devices/pci0000:00/0000:00:02.0/drm/card0/card0-VGA-1
lrwxrwxrwx  1 root root    0 Feb 13 12:38 card0-HDMI-A-2 -> ../../devices/pci0000:00/0000:00:02.0/drm/card0/card0-HDMI-A-2
lrwxrwxrwx  1 root root    0 Feb 13 12:38 card0-HDMI-A-1 -> ../../devices/pci0000:00/0000:00:02.0/drm/card0/card0-HDMI-A-1
lrwxrwxrwx  1 root root    0 Feb 13 12:38 card0-DP-2 -> ../../devices/pci0000:00/0000:00:02.0/drm/card0/card0-DP-2
lrwxrwxrwx  1 root root    0 Feb 13 12:38 card0-DP-1 -> ../../devices/pci0000:00/0000:00:02.0/drm/card0/card0-DP-1
lrwxrwxrwx  1 root root    0 Feb 13 12:38 card0 -> ../../devices/pci0000:00/0000:00:02.0/drm/card0

And this is what I got from edid, I run sudo the next time thinking it was privileges that didn’t get me what I wanted.

$ sudo get-edid
This is read-edid version 3.0.2. Prepare for some fun.
Attempting to use i2c interface
Looks like no busses have an EDID. Sorry!
Attempting to use the classical VBE interface
mmap /dev/zero: Operation not permitted
error initialising realmode interface
do you have full superuser (root) permissions?
I'm sorry nothing was successful. Maybe try some other arguments
if you played with them, or send an email to Matthew Kern <pyrophobicman@gmail.com>.

I have used a splitter from the monitor so 2 machines can use it (not at the same time obviously) and I am wondering whether that makes the difference. It may be reading the chip off the v-card of the pc that is off and getting confused!

Learning all the time, thank you, I’ll report back.


(Gus Fun) #6

OK, I changed the resolution in grub to half what I had before and changed the pass gfx to text from keep. Resolution in console is fine, void X is now full resolution. I’ll have to check what this vga=0x368 in the linux line does to the rest of my installations.
The screen did get a little brighter by removing the splitter but the result from the get-edid command was the same.


(Masato the Empty) #7

I actually don’t know what’s up with get-edid… I couldn’t get it to work either. I suspect that it only wants to use the i2c bus, which I don’t think Intel iGPU is using here, at least not for this purpose.

That’s why I had to find the edid gotten by the kernel in sysfs and run it through parse-edid.

I still think you should try grub in text mode if you have not done so yet, just to see if you get any different behavior. Especially if it may allow you to not use the vga= options. That’s an old setting that applies to vesafb console driver. Unless it’s just not working right, KMS gives you better results (as console resolution should end up being your monitor’s native resolution, 75 lines of text on a 1200-line monitor).

Then again, if KMS isn’t working for you even after turning off grub GFX mode, then you do what ya gotta do…


(Gus Fun) #8

I didn’t expect this but in a different installation I am running (Obarun and Artix) the same package with root privileges revealed more information, but through i2c again it was negative. This is the output of # sudo get-edid
I have not been able to get any output from parse-edid, unless it takes soooooo long that I am interrupting it before it finished by hitting return.

This is read-edid version 3.0.2. Prepare for some fun.
Attempting to use i2c interface
Looks like no busses have an EDID. Sorry!
Attempting to use the classical VBE interface

	Performing real mode VBE call
	Interrupt 0x10 ax=0x4f00 bx=0x0 cx=0x0
	Function supported
	Call successful

	VBE version 300
	VBE string at 0x11100 "Intel(R) Sandybridge/Ivybridge Graphics Chipset Accelerated VGA BIOS"

VBE/DDC service about to be called
	Report DDC capabilities

	Performing real mode VBE call
	Interrupt 0x10 ax=0x4f15 bx=0x0 cx=0x0
	Function supported
	Call successful

	Monitor and video card combination does not support DDC1 transfers
	Monitor and video card combination supports DDC2 transfers
	0 seconds per 128 byte EDID block transfer
	Screen is not blanked during DDC transfer

Reading next EDID block

VBE/DDC service about to be called
	Read EDID

	Performing real mode VBE call
	Interrupt 0x10 ax=0x4f15 bx=0x1 cx=0x0
	Function supported
	Call successful

������0��
         "l3x.��WR�'
PT��qO��������:�q8-@X,E��V136796
     �2KS
      �LEN LT2323pwA$Looks like VBE was successful. Have a good day.

(Masato the Empty) #9

ah, actually you need to feed it your edid file.
$ cat [path-to-edid_file] | parse-edid
or
$ parse-edid < [path-to-edid_file]

read-edid - might be that we don’t build it will some capability that Artix does build it with… that last bit of gobbledigook looks like a dump of your edid. It’s binary so it results in mosly unprintable chars (you need to run it through the parser and/or look at it in hex). That would indicate that the hardware seems to communicate fine (using DDC2). But you want to make sure you’re getting it back in Void. It should end up somewhere in sysfs.

But you’re probably OK on the EDID part if I’m understanding your previous post, re: lxrandr run from Void returning all your screen resolutions… And doesn’t seem the splitter should cause much issue (it might add load and possibly noise, but it’d have to be in pretty bad shape to degrade the EDID info…)


(Gus Fun) #10

You are right, I looked up that code and it is the model number of this refurb job monitor I got, a Lenovo if that makes it something better.

Anyway, I think I am going to let it rest as all visual problems have been solved and I will move into my sound problems. My speakers sound like earphones.

 Audio:     Card Intel 7 Series/C216 Family High Def. Audio Controller
 driver: snd_hda_intel bus-ID: 00:1b.0