Home | News | Download | Packages | Forum | Wiki | Github

Connman needs root


#1

Hi, guys. Got installed Void Linux yesterday(Cinnamon edition). Today i have changed my DE to Enlightenment. I like it, but have one problem - connman needs root privileges, so EConnMan cannot work with it. How to fix?


(Michael Aldridge) #2

I’m not familiar with Enlightenment, but it was my understanding that connmann was not a production ready piece of software. Are you sure it doesn’t just need you to be in some group?


(Benjamin) #3

From my personal experience, making conman a service normally works and doesn’t require root. although it seems to very, for example my desktop needs econnman to be launched as root in order to work (using the xfce desktop, so different DE as well)


#4

Thank you for your replies. I fixed it by installing version of Void Linux with Enlightenment preinstalled.


(Sebastian) #5

Hi guys,

I got this problem too.
After about 6h of trial and error, writing tons of new dbus rules, deleting everything and reinstalling the whole system i finally found a solution.
In /etc/dbus-1/system.d/connman.conf i changed

<policy context="default"> <allow send_destination="net.connman"/> </policy>

to

edit: this was not the solution!

<policy context="default"> <allow send_interface="net.connman.Manager"/> </policy>

Since before the change the error said “1 matched rule”, and the only rule relating to the problem was in connman.conf, i have no idea why this was necessary. The enlightenment livecd iso does contain the first version of connman.conf and is working, and my old virtual machine containing void with e20 also had no problems with connman.

If anyone could tell me what is going on here and confirm that my new rule does not harm security, that would be great.


[SOLVED] Unable to change wallpaper
(Sebastian) #6

Ok i found the rule blocking access to connman. It was not, as stated above, in connman.conf but in connman-nmcompat.conf:

<deny send_destination="org.freedesktop.NetworkManager"/>

This should not be the problem, as the error says:

Error /net/connman/technology/wifi: Rejected send message, 3 matched rules; type=“method_call”, sender=":1.16" (uid=1000 pid=1027 comm=“connmanctl “) interface=“net.connman.Technology” member=“Scan” error name=”(unset)” requested_reply=“0” destination=“net.connman” (uid=0 pid=982 comm="connmand -n ")

As you can see, destination interface is “net.connman”, but in the rule it blocks it is “org.freedesktop.NetworkManager”. Still, in a fresh setup with only enlightenment, connman and chromium installed (no NetworkManager), changing this rule to ‘allow’ let’s me use connman. I don’t know if this is a bug in connman or in dbus.


(Benjamin) #7

Thanks for the fix! Now I can run connman without gksu all the time.