Home | News | Download | Packages | Forum | Wiki | Github

Chrome installation


(xforce) #1

I’m trying to install Chrome using these instructions

When I’m at this step,

$ ./xbps-src pkg google-chrome

I get this error

[*] Updating `https://repo.voidlinux.eu/current/musl/x86_64-repodata' ...
ERROR: [reposync] failed to fetch file `https://repo.voidlinux.eu/current/musl/x86_64-repodata': Not Found
[*] Updating `https://repo.voidlinux.eu/current/musl/nonfree/x86_64-repodata' ...
ERROR: [reposync] failed to fetch file `https://repo.voidlinux.eu/current/musl/nonfree/x86_64-repodata': Not Found
[*] Updating `https://repo.voidlinux.eu/current/x86_64-repodata' ...
[*] Updating `https://repo.voidlinux.eu/current/nonfree/x86_64-repodata' ...
[*] Updating `https://repo.voidlinux.eu/current/aarch64/x86_64-repodata' ...
ERROR: [reposync] failed to fetch file `https://repo.voidlinux.eu/current/aarch64/x86_64-repodata': Not Found
[*] Updating `https://repo.voidlinux.eu/current/multilib/x86_64-repodata' ...
[*] Updating `https://repo.voidlinux.eu/current/multilib/nonfree/x86_64-repodata' ...
ERROR Failed to bind mount /proc at /home/x/void-packages/masterdir//proc (Permission denied)

I want to use Chrome because I couldn’t find any other way to use Spotify, I’m trying to use the webplayer with Chrome


(Erin) #2

Two suggestions:

  1. Won’t Chromium work?

  2. Have you got the correct subrepositories enabled? Instructions on how here


(xforce) #3

Widevine doesn’t work for me with Chromium, I need it for Spotify

I tried following the steps in 2, but it didn’t work for me,


(Michael Aldridge) #4

This looks like you’re not a member of the xbuilder group. To rectify this:

$ sudo usermod -aG xbuilder <username>

Then try again. The tip off is that the bind mount is failing which means you aren’t being allowed the use of the binaries that setup the chroot.


(xforce) #5

thanks, will try after I reinstalled void-musl


#6

Are you aware that chrome is glibc only? :wink:


(xforce) #7

no, but I can use this can’t I?
https://wiki.voidlinux.eu/Musl#glibc_chroot


#8

I haven’t been using chroots much so I can’t give you a qualified answer. In theory I’d say yes, but with something like chrome I have no idea if some issue would arise. Anyway, just try it :slight_smile:


#9

@xforce I’m just curious: did it work out for you? :slight_smile:


(xforce) #10

haven’t tried yet,
I have trouble installing void-musl-cinnamon, because the liveusb doesn’t start for me / freezes during startup when it loads the gui


#11

Cinnamon again:unamused:


#12

Yup.

I’ve also had random EFI issues with the October 2017 build and installation with cranky HP EFI. I’m glad I kept a 2016 ISO around.

At this point, it’s difficult to support musl for my official uses beyond basic DNS/MX/etc, because some tools distributed only as binaries don’t want to work even when making a local chroot with glibc available.

I hate to say it, but using glibc is the easiest way to make things work.