Home | News | Download | Packages | Forum | Wiki | Github

Brother MFC Printer


#1

While trying to get my printer to print, I ran across this with the ‘system-config-printer’ command, “/usr/share/system-config-printer/system-config-printer.py: not found”, Exit 127, but I do have the .py file. Any idea what’s going on?

I have the Brother MFC-5440cn printer setup, I can see it in the Cups web admin page, but when I print something, I get no paper output. At this point I’m just trying to troubleshoot to see if I can get it printing.

Thanks.


#2

You can try running xbps-install -Sf system-config-printer to force a reinstall of the package.


#3

Step 2 - pre required procedures could help, if you have not already done these of course.
http://support.brother.com/g/s/id/linux/en/instruction_prn1a.html?c=eu_ot&lang=en&prod=mfc5440cn_all&redirect=on

That links to this list here of commands to run and packages to install.
http://support.brother.com/g/s/id/linux/en/before.html?c=eu_ot&lang=en&prod=mfc5440cn_all&redirect=on#005

Not everything might be required in all instances and you might need to adapt it to Void commands and some of the packages could be named differently or be split into different sections too.
I think you need multilib too, 64 bit and 32 bit support. It says that on the last link.
And there was a recent upgrade issue where you have to manually redirect python3:


You’ve got to put paper in the intray too if you want it to come out :joy: (that is a joke in case of any misintepretation.)


#4

I tried the force install, nothing changed. I still get the system-config-printer.py: not found, message.

@hralgmir, Thanks for the python3 information. system-config-printer.py is working.
I have everthing required by Brother’s instructions installed, including tcsh . For a Slackware based distro, someone wrote to do thes e commands, “Slackware does not use /etc/init.d/cups it use /etc/rc.d/rc.cups so lets fix that by creating a softlink.
ln -s /etc/rc.d/rc.cups /etc/init.d/cups
One more thing, now we need to do what the install could not do since it was not linked correctly.
Change to the Brother directory
cd /usr/local/Brother/cupswrapper/
Now, run the cups wrapper
./cupswrapperMFC5440CN-1.0.2”

But Void doesn’t use the sysinit. I tried runniing the ./cupswrapperMFC5440CN-1.0.2 command but didn’t make a difference.

Thanks for the suggestions. Any other ideas?


#5

Void has services set up with links from /var/service (which is a symlink to the current runlevel, for the desktop environment it would be /etc/runit/runsvdir/default/ and in there are symlinks:
agetty-tty1 -> /etc/sv/agetty-tty1
These enable services which can be seen as directories in the /etc/sv directory. So you could check in /etc/sv and see if any cups or similar services can be enabled. Brother printers can have a long delay in Linux compared to Windows, a minute or two between hitting the print button onscreen and the paper coming out, not that I think you are even getting that far yet.
You might also try to print a test page from the command line, something like:

# lpr -P <printer-name> /usr/share/cups/data/testprint

I think there could be some gtk printer package that is needed to link a few desktop apps to the printer.


(Erin) #6

If cups is running you should be able to browse to http://127.0.0.1:631 and access the cups “gui”.


#7

I see this under /etc/sv:

ls -l /etc/sv/cupsd

total 4
-rwxr-xr-x 1 root root 24 Jul 2 10:06 run
lrwxrwxrwx 1 root root 26 Jul 2 10:06 supervise -> /run/runit/supervise.cupsd
[root@ghostdawg5 ~# ls -l /run/runit/supervise.cupsd
total 12
prw------- 1 root root 0 Sep 16 16:17 control
-rw------- 1 root root 0 Sep 16 16:17 lock
prw------- 1 root root 0 Sep 16 16:17 ok
-rw-r–r-- 1 root root 4 Sep 16 16:17 pid
-rw-r–r-- 1 root root 4 Sep 16 16:17 stat
-rw-r–r-- 1 root root 20 Sep 16 16:17 status

ls -l /etc/sv/cups-browsed

total 4
-rwxr-xr-x 1 root root 71 Aug 20 08:28 run
lrwxrwxrwx 1 root root 33 Aug 20 08:28 supervise -> /run/runit/supervise.cups-browsed
[root@ghostdawg5 ~# ls -l /run/runit/supervise.cups-browsed
ls: cannot access ‘/run/runit/supervise.cups-browsed’: No such file or directory.
As can be seen, the cups-browsed have a symlink but it show no such file/directory. Would it be stopping the printer from printing to paper?

@Erin, I can browse & access cups gui interface, that is what I’ve been using.

Thanks and sorry for late reply.


#8

I think cups-browsed should be running as a service, so if it isn’t properly up then that could be a problem. I’ve only helped friends set up printers I should add, so can’t provide exact details - perhaps someone else is currently running a printer and could check how they have set it up?


#9

I created the service for ‘cups-browsed’. I’m not sure if it should be a service or not. When I try to start it, I get this, "timeout: down: cups-browsed: 0s, normally up, want up"
Now when I do the status, it showing ‘1s’ instead of 0s.

What does those 0s & 1s represent? Thanks for the replies.