Home | News | Download | Packages | Forum | Wiki | Github

Broken, unresolvable shlib `libvpx.so.4'


#1

Anyone else getting this while trying to update?


(kenny_w) #2

Me too. Uninstalling the packages in question didn’t help either, and now I can’t re-install them :frowning:


#3

You only have to wait until buildbots finished their work.
Try again later.


(kenny_w) #4

I got the libvpx libvpx-devel libvpx-tools packages installed now but the rest of the packages I uninstalled can’t be re-installed


#5

Thank you. I didn’t know about such a thing


#6

Sorry, did this get resolved? I originally assumed that I just needed to wait for the packages to get updated in my mirror, but it’s been weeks and I’m still getting this.

EDIT: I’m using repository=http://repo2.voidlinux.eu/current/musl and the musl build, if it’s relevant.


(maxice8's favorite salad) #7

libvpx stuff got resolved some time ago.


#8

I am willing to consider the possibility that this is a different issue, but I am inclined to disagree:

# date
Sun Apr 15 16:37:03 EDT 2018
# xbps-install -Su
[*] Updating `http://repo2.voidlinux.eu/current/musl/x86_64-musl-repodata' ...
x86_64-musl-repodata: 1490KB [avg rate: 579KB/s]
[*] Updating `https://repo.voidlinux.eu/current/musl/nonfree/x86_64-musl-repodata' ...
gst-plugins-bad-0.10.23_23: broken, unresolvable shlib `libvpx.so.4'
Transaction aborted due to unresolved shlibs.

(maxice8's favorite salad) #9

gst-plugins-bad was removed from our ports (place where we define how to build software which makes into the distro), it won’t be updated to use libvpx.so.5 because it doesn’t exist anymore. the solution is removing it.