Home | News | Download | Packages | Forum | Wiki | Github

Blank screen, trying to install void-xfce4.iso


(SethR) #1

Hello, I’m getting blank screen / no signal to monitor. In other distros I pass nomodeset to the kernel and that resolves the issue. I tried that in void linux, and that does get me past the no-signal stage, but then I’m presented with a blank screen with flashing cursor(?) in the top left. Every ten seconds or so, some information briefly flashes on the screen. I took a screenshot, attached below. How do I advance past this? It works when I use the integrated graphics but I want to know how to solve it the right way. Pardon my noob question, I found Void by seeking the most attractive systemd alternative I could find. Thanks!

Specs:
Sandy Bridge i7 CPU
Asus p8z77-v pro mobo, i tried swapping from Asmedia SATA ports to Intel SATA with no effect
GTX970 GPU
void-live-x86_64-20170220-xfce.iso, and I have verified the sha256sum

Screenshot of briefly flashing text:


(Masato the Empty) #2

This means you’re waiting for Xorg to start, and it’s not starting correctly; the info that flashes on your screen is part of what’s on VT1, which only appears for a split second before you’re put back on VT7 (where X is currently not working…) Just switch to VT1 and log in as root so you can go through the void-setup installation routine from the CLI.

If you do a net install, you can get an up-to-date installation that will more likely work when you boot it. Otherwise, you’ll have the same problem after you boot into the newly-installed system, and it won’t go away until you do an update from the CLI.

It seems likely the [Xorg/GUI-related] packages that are in the ISO would be to blame, and an updated system would work better; the April 20 Xorg ISO has issues on my own hardware (even when booting on the iGPU), and doesn’t work right in some of my VM setups, where in all cases an up-to-date void install worked fine.


#3

If you blacklist nouveau kernel module loading for nvidia GPU
Xorg should fallback to generic vesa driver.
Tab the installer boot menu.
Type:
modprobe.blacklist=nouveau
Hit Enter key to boot


Xorg Nvidia Bumblebee Problems
(SethR) #4

Ok that did work. Once I void-installer’d from net source, I only require ‘nomodeset’ without needing to switch from VT7 to VT1.

cardinal, I’ll look into the difference between nomodeset and modprobe.blacklist=nouveau when I get a chance.

I probably would’ve wanted nouveau if that was an option, but perhaps I need the proprietary nvidia drivers or the generic vesa driver (once I read what that is and the performance implications).

Thanks much for the help guys. This is the first distro that feels right for me, in spite of my ineptitude. I may have more questions, hopefully not too many, the void wiki is pretty good and the arch wiki is a good supplemental reference.

EDIT: It seems that xfce4 and lxdm are not installed now that I check xbps-query -l
Not sure how I jacked that up, I guess I can just manually install them.


#5

I’m going off of memory and one of the more experienced users may correct me, but there’s one question during the installation that I always get wrong and end up without the window manager. I think it’s the one of doing a net vs. local install. If you answer “net” you won’t get the window manager and have to manually install it.


(Erin) #6

You are correct. It states so in the installation guide. Update the system then install LXDE.