Home | News | Download | Packages | Forum | Wiki | Github

Artifacts after freetype update


#21

good ol’ xfce :wink: I recommend the windowck-plugin to integrate window controls in the top panel, isn’t installed in the screenshot though.


(eggshell88) #22

Since I don’t have any old freetype packages in my cache and have not yet found any way to download the void package anywhere: where can I get old void packages?

I tried building freetype2 from source but that only broke dependencies…
Isn’t there something like an archive like Arch Linux has?


#23

What do you mean by it “broke dependencies”?
Void has no archive as far as I know, as you can just rebuild older packages from git and then downgrade to them.


(maxice8's favorite salad) #24

Trying to build an old version freetype from xbps-src is a mighty fun adventure of git cherry-pick other packages updates so it fills up


(eggshell88) #25

Well it did not break them directly. It was rather the fact that some packages depended on freetype-devel and I did not find any source code to build a “freetype-devel”. The freetype-devel package in the repos is 2.8.1, while the freetype I built from source was 2.8.
So a few applications like sddm did not work because they were probably expecting a freetype-devel package, which I removed.

Building from xbps-src. Well, currently it builds 2.8.1 of course. I honestly didn’t get too much into that, it just seemed easier to download the tar ball and build it myself.


#26

Ah, I understand now. When you build freetype it will also build the devel package with it.
(And it would be too easy if you could just download old packages! :stuck_out_tongue:)


(eggshell88) #27

Oh, well, then I shall try again. Thx :wink:

Still, a site like archive.archlinux.org for Void would be fantastic :slight_smile:


(eggshell88) #28

Well. Turns out freetype.2.8_1-x86_64.xbps is available on repo.voidlinux.eu/current .
That oughta do it :wink:


#29

Doesn’t seem that it’s there anymore. Is there a way to downgrade some other way? I tried building from the old template which fails at do_build(with the current bootstrap/tools).


#30

The old template still builds for me with the current bootstrap. Could you post the error you got?


#31
make: *** No targets specified and no makefile found.  Stop.=> ERROR: freetype-2.8_1: failed to run do_build() at line 13.

#32

I can’t seem to reproduce that error.
What architecture are you building it on and what commands are you using to build it?


#33

Interestingly enough it seems that it builds now after re-initializing the bootstrap. Thanks for answering.


(eggshell88) #34

Should you still want freetype2.8 as xbps package, it is still available on repo2.voidlinux.eu :wink: