Home | News | Download | Packages | Forum | Wiki | Github

Artifacts after freetype update


#1

Since the latest update for freetype firefox and thunderbird have trouble rendering fonts properly. So far they are the only applications I encountered with this sort of problem. I already rebuilt the font cache and reinstalled firefox & thunderbird, as well as restarted my computer. Here’s a screenshot to better illustrate my problem.


Fixing fonts in an application
[Solved] Discord bad font rendering and other programs too
Icecat 52 font rendering issue [Solved]
#2

I am also affected by this, downgrading to freetype-2.8_1 fixes it.


#3

Unfortunately I don’t have the older package anymore, where can I get it?


#4

It should remain in your cache so you can use xdowngrade from xtools to use the old package again:
xdowngrade /var/cache/xbps/freetype-2.8_1.x86_64.xbps

Otherwise I think you might have to build it from the old template.


#5

Ok , I can now confirm downgrading fixes the issue.


(Jacob Moen) #6

Yes, much better! :slight_smile:

How do I hold / unhold this package?

xbps-pkgdb -m hold freetype-2.8_1 - is that correct?


#7

xbps-pkgdb -m hold freetype freetype-devel


(Jacob Moen) #8

And I guess unhold will undo the hold?


(Jacob Moen) #9

They still want to be updated even when held, what am I missing? Never mind, figured it out!

[jacmoe@jacmoe-pc ~]$ ./update.sh 
[*] Updating `https://repo.voidlinux.eu/current/x86_64-repodata' ...
[*] Updating `https://repo.voidlinux.eu/current/nonfree/x86_64-repodata' ...
Found freetype-2.8.1_1 (hold) in repository https://repo.voidlinux.eu/current
Found freetype-devel-2.8.1_1 (hold) in repository https://repo.voidlinux.eu/current

Name           Action    Version           New version            Download size
freetype       hold      2.8_1             2.8.1_1                - 
freetype-devel hold      2.8_1             2.8.1_1                - 

Free space on disk:            409GB

Do you want to continue? [Y/n] Y

[*] Downloading binary packages

[*] Verifying package integrity

[*] Running transaction tasks

[*] Configuring unpacked packages

0 downloaded, 0 installed, 0 updated, 0 configured, 0 removed.

(Jacob Moen) #10

This morning, when I woke up and fired up Firefox, the text was all blurry and wonky.

Normally something that a cup of coffee would fix.

When it didn’t fix it, I started to panic!! OMG, I am going blind! :open_mouth:

I am really glad that it was freetype that was the culprit… :smile:


(Ibn Saeed) #11

I have the same problem, but i am not able to downgrade. So im stuck with the artifacts.

Here is the message i get:

sudo xdowngrade /var/cache/xbps/freetype-2.8_1.x86_64.xbps
index: added `freetype-2.8_1' (x86_64).
index: 1 packages registered.
freetype-2.8_1 (install) breaks installed pkg `freetype-devel-2.8.1_1'
Transaction aborted due to unresolved dependencies.

(Nashat) #12

hi @IbnSaeed, have you tried removing the installed freetype-devel package?


(Jacob Moen) #13

First downgrade freetype-devel, then freetype - it works. :slight_smile:


(Ibn Saeed) #14

Thanks it worked.


#15

This has been fixed by https://github.com/voidlinux/void-packages/pull/7722 and https://github.com/voidlinux/void-packages/pull/7723

You can update to 2.8.1_1 without issues now.


(Jacob Moen) #16

Unrelated to Void, I think, but all Electron based apps renders horribly with Freetype 2.8.1_1
freetype_vscode

So, I downgraded and held them (the freetypes), at least for now.

The other issues were totally fixed, so thanks! :smile:


#17

Freetype is broken for chromium and chromium based programs as well but I think this pull will fix it
https://github.com/voidlinux/void-packages/pull/7733

EDIT: Freetype isn’t broken on chromium and chromium based programs, see below


#18

I don’t think so. This PR is meant to fix the issue for applications that are based on qt-webengine like qupzilla and qutebrowser. AFAIK electron ships it’s own copy of chromium. So to get this fixed, you need to report the issue to the Electron developers and get them to patch or update their chromium base.

About chromium itself, it also ships it’s own skia version, so fixing it for qt-webengine will not change that. If you are using the current chromium from the Void repository and are still experiencing font rendering issues, please file an issue against void-packages on github. However I would assume (I don’t use chromium myself) that the chromium build in the repository is not affected by this issue isn’t affected by this issue since Google fixed this issue some time ago in the skia version bundled with their chromium releases.


#19

Ah my mistake, I didn’t read the PR carefully enough.
Rendering on chromium is fine.


#20

What is this DE??