After upgrading I can't access the system


#1

I hope they’re okay.
after xbps-install -Su two days ago, after the login screen, the system is blocked or something.
I thought it had something to do with this. The description of the problem is similar to what happens.


uninstall networkmanager, remove the service and nothing.

In recovery mode I didn’t have an internet connection. so I reinstalled the entire system from usb.

The first thing I did was uninstall networkmanager and make sure that dhcpd connected me to the internet. after that
xbps-install -Syu, and the same thing happens again. I log in and the nm-dispatcher message does not appear but the cursor is stopped, not flashing, for hours.
reinstallation is clean, do not add any new programs or touch any settings.
I’m stuck on this.
Any suggestions?


#2

Which image are you using? It looks like nm-manager (networkmanager) is the culprit. Have you tried using the minimal image and use something other than network-manager to setup your network?


#3

void-live-x86_64-20171007-xfce.iso
this is the image I used on the date it says to reinstall void, as long as I updated so far I had no problems.

I haven’t tried a minimum image yet.
At the moment I don’t have the time to install it, I’ll continue temporarily with what was installed and I won’t update it.


#4

I have exactly the same problem as @Apko . Did a clean install of void-live-x86_64-20171007-xfce.iso then made a full upgrade, now every time I try to login to my account I’m getting a blank black screen with these messages:

nm-dispatcher: req:1 ‘hostname’: new request (0 scripts)
nm-dispatcher: req:1 ‘hostname’: completed: no scripts
nm-dispatcher: req:2 ‘up’ [eth0]: new request (0 scripts)
nm-dispatcher: req:2 ‘up’ [eth0]: completed: no scripts
nm-dispatcher: req:3 ‘connectivity-change’: new request (0 scripts)
nm-dispatcher: req:3 ‘connectivity-change’: completed: no scripts

And its stuck there no matter how long I wait. Tried disconnecting my Ethernet cable, but it didn’t change anything, except that I’ve seen only a message about req:1 . Now I’m afraid to upgrade my another void machine


(oliver) #5

Can you use ctrl-alt-f2 to log into a virtual terminal?


#6

Upgrade of xf86-video-ati (18.0.1_1 -> 18.0.1_2) xorg-server (1.19.6_4 -> 1.20.0_1)
caused black screen login error on my x86_64 glibc lxde system running Linux voidlinux 4.9.93_1 with xf86-video-ati (radeon) driver.
I disabled hardware acceleration by adding nomodeset to kernel command in boot loader menu… I removed all xf86-video-* and xf86-input-* packages until I was allowed to remove xorg-server-1.20.0_1 . I used xdowngrade from xtools package to install previous versions of removed packages from my cache to restore direct hardware rendering.
Use xbps-pkgdb to hold downgrade packages.
The network messages on my system in the black screen were normal.

Reference:
Xorg 1.20 segfaults (using Xfce / xf86-video-nouveau) #14771
nvidia340 conflicts with xorg-server because of xserver-abi-video>23_1 #14817


#7

do you know if this issue has been fixed at the latest void? (so that no manual intervention is required)